Flickering hid lights - after market by AngryDog

Guys, I fitted an aftermarket hid light kit to my zt with projector head lamps at the weekend.
They flicker when turned on and I can't understand why.
I've tried different bulbs and ballasts and it's the same.

I know the kit was only £30 but I have been told that this shouldn't matter.

I don't have any anti can bus or flicker boxes fitted

If anyone could help I would be most appreciative!


Posted 23 Aug 2011, 23:12 #1 

User avatar
I assume you mean that they flicker more that once. A single pulse of light is normal as they need an initial shock of 35,000 volts to start them.
People call me average, but I think that's mean!
Give a man a fish and he will eat for a day; teach a man to fish and he will eat for a lifetime; give a man religion and he will die praying for a fish.

Posted 28 Aug 2011, 07:01 #2 

Yes flicker more than once.

Im told it may be the LSM (Light Switch Module). I've got another new one but im going to test the bulbs by wiring them straight to 12v, and seeing if they flicker. If it is the LSM then I'll get it coded to the car.

Posted 31 Aug 2011, 20:48 #3 

User avatar
Seem to remember my aftermarket ones did this, not very noticable but it was there but before I got round to investigating it I managed to obtain some OEM units :).
You can swap the LSM over just to see if it makes a difference but don't drive to far with it in or you will end up with a mismatch on your mileage data.


Posted 01 Sep 2011, 06:11 #4