Parking Sensor ECU Position (When fitted with H/K Setup) by carlpenn



carlpenn
I have the H/K Set up on my Car so there is a Black box (Amp?) where the Parking Sensor ECU (Engine Control Unit) would go, so where would Rover have fitted the ECU in this Scenario? I had a look at the N/S but there appears to be no fitting positions there? Scratching my Head with this one :p
Upgrades:

Fitted Electric Memory Seat, Leather Cubby Lid, Wood Dash, Message Centre.

Posted 09 Jun 2013, 12:14 #1 

User avatar
JakeWilson
On Saloons with highline, the ECU is fitted underneath the sat nav drive IIRC

Posted 09 Jun 2013, 13:20 #2 

User avatar
Alan
Yep, Jake is right they go in between the sat nav drive and amp. May depend which sensor kit you have, mine are aftermarket [unsure of the make, I think they are just generic] and the ecu fits perfectly in the gap.
I did have to use tape though as no mounting holes, but if you had the bracket out the car I guess you could make some.

Posted 09 Jun 2013, 16:01 #3 


carlpenn
Cheers for the info.

Question 2 now lol.

My Wiring Plug doesn't seem to fit the ECU Socket? Also, there appears to be no Speaker Plug, could this be something different or is it the ECU Plug for Sensor?

The Plug is Central here:
Image
Upgrades:

Fitted Electric Memory Seat, Leather Cubby Lid, Wood Dash, Message Centre.

Posted 09 Jun 2013, 16:06 #4 

User avatar
JakeWilson
The plug for the speaker should be under the parcel shelf. Your ECU should have a black and white socket, the loom from the sensors goes into the ECU and the connector pictured into the black socket on the ECU.

Posted 09 Jun 2013, 22:40 #5 

User avatar
Duncan
Later cars don't have a PDC speaker, they use the one in the IPK (Instrument pack (IPK from the German)). Not sure on the changeover date, but my 2004 uses the IPK. Looking at the plug and the colours, I'm pretty sure that is one of the two for the PDC, as Jake says. You will have to release the retaining cam on the connector before it will go in, of course.
Image

Posted 10 Jun 2013, 17:47 #6 


carlpenn
Cheers for responses, Will let you know how I get on, just have to source the Sensors now - I have a set for Tourer but not the Saloon :p Ebay here I come lol !!
Upgrades:

Fitted Electric Memory Seat, Leather Cubby Lid, Wood Dash, Message Centre.

Posted 10 Jun 2013, 18:05 #7 

User avatar
Arctic
(Trader)
spliced mine as i too could not find the PDC speaker and when all pluged in the sensors wouls not sound off but as soon as i added the spliced in wiring and speaker i can hear the sensors working

Image1

Image2

Image3

Image4

Image5

this plug fits into the bumper wiring for the sensors
Image6

While inside the boot area the white clips fits into the parking aid ywc 105 180
Image7

And the black clips also fits into the same box you must make sure the cam is flat down otherwise the clips will not fit in properly
Image8

Double sided tape ready for fitting back against the rear wing panel
Image9

Image10

Image11

After fitting i had no sound and could not find the speaker under the rear parcel shelf i relised that it used the IPK sounder but i still got no sound so i fitted and spliced in a speaker works great
Image12

Image13

Image14

Image15

Hope this helps in some way Arctic.

Posted 10 Jun 2013, 21:39 #8 


carlpenn
Cheers Steve, informative as always :D
Upgrades:

Fitted Electric Memory Seat, Leather Cubby Lid, Wood Dash, Message Centre.

Posted 11 Jun 2013, 07:00 #9 


Top