Intercooler pipe leak by Bermudan 75


User avatar
Bermudan 75
I have replaced my intercooler with one that includes the welded 90 degree pipe.

Performance wise the car seems fine, however, the area around the rear passenger light cluster gets a coating of sooty deposits.

The are no visible signs of black smoke when driving as when the intercooler o-rings have blown.

I was wondering if the cause of the deposits is the top intercooler hose weeping or not being tight enough to the intercooler?

Does anyone have any thoughts?

Cheers

Mike
Image

Posted 16 Oct 2015, 16:48 #1 

User avatar
Arctic
(Trader)
Mike we can take a look at the meet over the weekend

Posted 17 Oct 2015, 00:20 #2 

User avatar
Bermudan 75
Hi Steve,

I will be attending on Sunday now, not today. I will remove the intercooler top hose, clean the inside where it surrounds the intercooler pipe and see if the deposits re-occur on the trip to the Nano.

Cheers

Mike
Image

Posted 17 Oct 2015, 09:17 #3 


karaev
Check the o rings between the plastic pipe and the intercooler....they're leaking probably.Replace those with Viton rings and problem solved....

Posted 15 Dec 2015, 10:16 #4 

User avatar
Arctic
(Trader)
karaev wrote:Check the o rings between the plastic pipe and the intercooler....they're leaking probably.Replace those with Viton rings and problem solved....


Hi Karaev.
Mike as the new welded intercooler so no O-rings involved, it turned out to be the intercooler hose had mushroomed on the end and was not making a good enough seal, removed and re-fitted solved the problem, most intercooler bends that get fitted at the nano meet now have the modified three O-rings as opposed to the usual
two, thus making it more secure Arctic.

Link below
intercooler-o-ring-bend-modification-t7089.html?hilit=intercooler#p66445

Posted 15 Dec 2015, 10:29 #5 


Top